starts but weak spark

Hunter cruise

Member
Aug 26, 2021
10
0
32
22
Ok so i finished rebuilding my blaster after destroying the top end( new top end is ported and polished with a shaved head) I also replaced all the seals while i had it apart. but my problem is i put the motor in and it started up 2nd kick however it doesn't idle and bogs down and smokes and has premix coming from the exhaust however if i shut the gas off it runs perfect seconds before running out of gas (I premix at 32:1) I thought it was getting flooded so i pulled the carb and cleaned it really good and the seat is closing fine (It's a stock carb and stock jetting) So then i start to think maybe it's not getting enough spark. i pulled the plug and grounded it to the cylinder and there was spark but very very light spark. I then cleaned the ground for the coil all the way to shiny bare frame and it still has light spark. What should my next step be? I really need help figuring this out so i can do a proper break in.
 
Is the spark yellow or blue?

What pipe are you using? Part of your problem is probably jetting related !
What jets do you have in it and what air screw and needle set at?

As to spark, start at the stator and work your way out. Check ohms of stator, pick-up coil, and ignition coil. Check plug boot separate. Check ALL connections are clean and tight. A dab of dielectric grease won’t hurt. Also bypass both switches to rule them out.
 
Is the spark yellow or blue?

What pipe are you using? Part of your problem is probably jetting related !
What jets do you have in it and what air screw and needle set at?

As to spark, start at the stator and work your way out. Check ohms of stator, pick-up coil, and ignition coil. Check plug boot separate. Check ALL connections are clean and tight. A dab of dielectric grease won’t hurt. Also bypass both switches to rule them out.
I have a fmf exhaust not sure what model, it was on it when i got it. As far as the jetting it is stock with the stock carb, not sure what size that would be. and the spark is almost non existent. every few kicks i'll see a small spark unsure of the color. And what should my ohm reading be for the stator and coil if they are good?
 
You’ll find the specs in the manual in this link
https://www.blasterforum.com/thread...ervice-and-owner-manuals-free-download.17325/

Only one I know off the top of my head is the plug boot, 500k, tested separately from the plug wire ( it screws onto the wire)

Stock jetting IS NOT sufficient for the pipe, you’d be minimum 270

Use only OEM parts for replacement of electronics
Thank you so much, i will start testing when i get home today. and as far as my jetting goes what all plays a part in jetting it correctly is there some sort of way for me to figure out a ballpark of where it should be with my mods?
 
Go to FMF website, it will give baseline jetting specs. That’s how I remember the 270 main. Pay attention to the other items such as filter, air box, elevation. You have to adjust for your setup. Such as any nonstock filter, no lid, porting. Learn how/what a plug chop is and how to do it.
 
Go to FMF website, it will give baseline jetting specs. That’s how I remember the 270 main. Pay attention to the other items such as filter, air box, elevation. You have to adjust for your setup. Such as any nonstock filter, no lid, porting. Learn how/what a plug chop is and how to do it.
I couldn't find out how to check my stator. I checked the coil and it's good. I will definitely be properly jetting it soon but first i gotta figure out my bogging situation. i don't think it's getting enough spark( it's a blue spark in the dark but not very bright at all, i cant see it in the daytime) I have fuel coming out the exhaust so maybe it isn't enough spark too burn all the fuel
 
I couldn't find out how to check my stator. I checked the coil and it's good. I will definitely be properly jetting it soon but first i gotta figure out my bogging situation. i don't think it's getting enough spark( it's a blue spark in the dark but not very bright at all, i cant see it in the daytime) I have fuel coming out the exhaust so maybe it isn't enough spark too burn all the fuel
also what isn't making since to me is why it runs perfect and idles perfect right before it runs out of fuel.
 
Thank you so much, i will start testing when i get home today. and as far as my jetting goes what all plays a part in jetting it correctly is there some sort of way for me to figure out a ballpark of where it should be with my mods?

also what isn't making since to me is why it runs perfect and idles perfect right before it runs out of fuel.

Perfect indication of poor jetting, air screw adjustment, or fuel level too high. Look for how to PROPERLY clean the carb. Just spraying underside isn’t how.
Good possibility you have a leaking float valve or even the O-ring on outside of needle seat.

https://www.blasterforum.com/threads/great-carb-tuning-guide.9846/

https://www.blasterforum.com/forums/carburetor.138/

https://www.blasterforum.com/threads/easy-and-almost-free-way-to-stop-leaky-carbs.33335/


 
Perfect indication of poor jetting, air screw adjustment, or fuel level too high. Look for how to PROPERLY clean the carb. Just spraying underside isn’t how.
Good possibility you have a leaking float valve or even the O-ring on outside of needle seat.

https://www.blasterforum.com/threads/great-carb-tuning-guide.9846/

https://www.blasterforum.com/forums/carburetor.138/

https://www.blasterforum.com/threads/easy-and-almost-free-way-to-stop-leaky-carbs.33335/

I cant figure out how to post onto the jetting thread but here's my answers
1) what carb do you have??? Stock

2) What type of aftermarket exhaust do you have? Fmf

3) What type of airfilter do you have? K&N

4) What kind of air box set up do you have?? Stock no lid

5) What size pilot jets are you using? stock

6) What size main jets are you using? stock

7) What needle position? Stock

I've never done carb tuning but i'm afraid that might be my problem.
 
I cant figure out how to post onto the jetting thread but here's my answers
1) what carb do you have??? Stock

2) What type of aftermarket exhaust do you have? Fmf

3) What type of airfilter do you have? K&N

4) What kind of air box set up do you have?? Stock no lid

5) What size pilot jets are you using? stock

6) What size main jets are you using? stock

7) What needle position? Stock

I've never done carb tuning but i'm afraid that might be my problem.
The motor ran fine with the carb before the rebuild the only thing i changed besides the top end was the reeds but that's not the problem bc i swapped the old ones into it and it still does it. Here's my check list.
Stator,coil,plug,plug cap,reeds and the flywheel all of these have been swapped with parts i know work. And it's still runs like sh*t
 
“Stock” is not a good answer. How do you know it’s stock? When you have the carb apart write the numbers down. Then when someone asks you what main jet you use you can give a definitive answer. BTW, “stock” main jet depends on what year model.